[Logo] TCC discussion forum
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 

Nothing is displayed RSS feed
Forum Index » tcMenu Arduinio library
Author Message
Tiqo01


Joined: Apr 16, 2019
Messages: 2
Offline
Hello,
I would like to have your help, I used your library to create my menu, I use an arduino mega 2560, a LiquidCrystal screen 20 * 4 I2C and a rotary encoder on pins 2,3 and 4, when I compile and transfer the program to my card nothing is displayed.
My screen works very well because I have already tested, I did not change anything in the program generated by the GUI. I put the right I2C address and the right pins in parameters.
Can you please help me !
smilie
davetcc


Joined: Jan 19, 2019
Messages: 532
Offline
Hi there,

We will try our best to get you up and running with TcMenu.

There are many forms of i2c display. Could you please tell me which i2c backpack that you are using with your display. What is important is the IO expander chip on the backpack and the pin configuration it uses.

LiquidCrystalIO can work with nearly all forms of i2c backpack but the configuration may need to be changed. However, should you have an unusual backpack I can show you how to make it work with your present library too with little effort.

If you could also send me the details of your backpack and the .emf file that would be in the same directory as your sketch. So I can see how it’s currently set up.

Many Thanks
Dave.

Tiqo01


Joined: Apr 16, 2019
Messages: 2
Offline
Thank you for your reply !
it works perfectly now I used another library instead of the LiquidCrystalIO.
davetcc


Joined: Jan 19, 2019
Messages: 532
Offline
That’s great. It would still be good if you could send me the type of backpack that you had so I could take a look at why it wasn’t supported.

Don’t forget that if you adjust the display plugin file it will be replaced should you generate the code again. The easiest way out of this is to:

1. Rename the two display files
2. Set the display to no display in TcMenu designer.

Thanks
Dave.
 
Forum Index » tcMenu Arduinio library
Go to:   
Mobile view
Powered by JForum 2.7.0 © 2020 JForum Team • Maintained by Andowson Chang and Ulf Dittmer

This site uses cookies to analyse traffic, serve ads by Google AdSense (non-personalized in EEA/UK), and to record consent. We also embed Twitter, Youtube and Disqus content on some pages, these companies have their own privacy policies.

Our privacy policy applies to all pages on our site

Should you need further guidance on how to proceed: External link for information about cookie management.